jump to navigation

Catatan : OSPF Virtual Links October 5, 2009

Posted by ZoeL in Cisco, Routing.
Tags: , ,
trackback

Virtual link digunakan untuk menghubungkan area yang terpisah dari area 0 (backbone), atau menghubungkan area yang terbelah (partitioned).

Contoh topologi :

OSPF Virtual Link

Koneksi R1 & R2 merupakan area backbone (area 0), sedangkan koneksi R1, R2 dan R4 berada di area 10. R4 juga punya koneksi ke area 20. R1 juga memiliki koneksi ke R3 yang berada di area 5. Karena sesuai syarat OSPF bahwa setiap area yang bukan area 0, harus memiliki koneksi ke area backbone (area 0), maka area 20 harus di buatkan virtual link yang melalui R4-R1 atau R4-R2, sehingga area 20 memiliki koneksi ke area backbone.

Case lainnya, ketika koneksi R1 dan R2 putus. R4 melihat ada dua area backbone yaitu R1 dan R2. R1 dan R2 menjadi memiliki area 0 yang terpisah (discontiguous area). Masalah ini bisa diatas dengan membuat sebuah virtual link dari R1 ke R4 kemudia dari R4 ke R2. Sehingga dengan bantuan virtual link, backbone R1 bisa terkoneksi dengan backbone di R2.

Berikut saya perlihatkan bagaimana area 20 di R4 (diwakili oleh Loopback dengan IP 4.4.4.4) tidak bisa tampil di router R3 dikarenakan Area 20 tidak memiliki koneksi ke area backbone.

R1
!
interface FastEthernet0/0
description To R3
ip address 13.13.13.1 255.255.255.0
!
interface FastEthernet0/1
description To R2
ip address 12.12.12.1 255.255.255.0
!
interface FastEthernet1/0
description To R4
ip address 14.14.14.1 255.255.255.0
!
router ospf 1
network 12.12.12.1 0.0.0.0 area 0
network 13.13.13.1 0.0.0.0 area 5
network 14.14.14.1 0.0.0.0 area 10
!

R2
!
interface FastEthernet0/0
description To R4
ip address 24.24.24.2 255.255.255.0
!
interface FastEthernet0/1
description To R1
ip address 12.12.12.2 255.255.255.0
!
router ospf 1
network 12.12.12.2 0.0.0.0 area 0
network 24.24.24.2 0.0.0.0 area 10
!

R3
!
interface FastEthernet0/0
description To R1
ip address 13.13.13.2 255.255.255.0
!
router ospf 1
network 13.13.13.2 0.0.0.0 area 5
!

R4
!
interface Loopback0
description Area 20
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
description To R1
ip address 14.14.14.2 255.255.255.0
!
interface FastEthernet0/1
description To R2
ip address 24.24.24.1 255.255.255.0
!
router ospf 1
network 4.4.4.4 0.0.0.0 area 20
network 14.14.14.2 0.0.0.0 area 10
network 24.24.24.1 0.0.0.0 area 10
!

Dari config diatas, mari kita lihat routing table di R3.

24.0.0.0/24 is subnetted, 1 subnets
O IA    24.24.24.0 [110/3] via 13.13.13.1, 00:09:06, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O IA    12.12.12.0 [110/2] via 13.13.13.1, 00:09:06, FastEthernet0/0
13.0.0.0/24 is subnetted, 1 subnets
C           13.13.13.0 is directly connected, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O IA    14.14.14.0 [110/2] via 13.13.13.1, 00:09:06, FastEthernet0/0

di routing table di atas, tidak terlihat ada network area 20 di R4 (Subnet 4.4.4.4/32), sekarang kita buat sebuah virtual link dari R4 ke R1 dan R4 ke R2. Note : Router-ID diperlukan untuk mengaktifkan virtual link ke router tujuan. Virtual link tidak bisa aktif apabila router-id yang digunakan salah.

R1
!
router ospf 1
router-id 14.14.14.1
area 10 virtual-link 4.4.4.4
!

R2
!
router ospf 1
router-id 24.24.24.2
area 10 virtual-link 4.4.4.4
!

R4
!
router ospf 1
router-id 4.4.4.4
area 10 virtual-link 24.24.24.2
area 10 virtual-link 14.14.14.1
!

Hasil Routing table yang ada di R3 menunjukkan area 20 sudah berhasil dikenali.

4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 13.13.13.1, 00:00:36, FastEthernet0/0
24.0.0.0/24 is subnetted, 1 subnets
O IA    24.24.24.0 [110/3] via 13.13.13.1, 00:04:06, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O IA    12.12.12.0 [110/2] via 13.13.13.1, 00:03:40, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O IA    14.14.14.0 [110/2] via 13.13.13.1, 00:04:11, FastEthernet0/0

Keuntungan lainnya menggunakan virtual link, kalau koneksi antara R1 dan R2 terputus, virtual link bermanfaat untuk menghubungkan R1 dan R2 melalui virtual link yang ada di R4.

Catatan tambahan :

  • Interface yang akan di jadikan koneksi virtual link tidak perlu bisa saling ping (reachable). Asalkan kedua router memiliki router-id yang dikenali oleh router2 yang dijadikan transit
  • area 0 merupakan area backbone. Area lain harus punya koneksi dengan area 0.
  • untuk area yang terpisah dengan perantara area lain dan beberapa router, jalankan multiple virtual link untuk mencapai area backbone.
  • ABR = Area Border Router, adalah router yang digunakan untuk menyebrang antar area. Biasanya di router yang menjadi ABR, di beberapa interface-nya terkoneksi ke lebih dari 1 area.

.end.

Comments»

1. gillette venus razor samples - March 27, 2014

gillette indianapolis

2. handy spy - July 7, 2013

whoah this weblog is wonderful i like reading your posts.
Keep up the great work! You realize, lots of persons
are searching around for this information, you can help them greatly.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: