jump to navigation

BGP transit via non-BGP Routers dengan menggunakan Tunnelling July 17, 2009

Posted by ZoeL in Cisco, Routing.
Tags: , ,
trackback

Di post saya sebelumnya mengenai synchronization, memperlihatkan bagaimana redistribute membantu melewatkan koneksi BGP melalui non-BGP router. Kali ini saya coba menjelaskan alternatif lain dengan menggunakan Tunneling.

bgp over tunnel

Dengan menggunakan tunneling, R1<->R3 mempunyai sebuah koneksi virtual yang bisa digunakan untuk BGP lewat. Karena itu redistribute BGP ke IGP seperti ketika melalui R3, tidak perlu dilakukan.

Config:

R1
!
interface Tunnel1 //tunnel ke R2
ip address 155.1.12.1 255.255.255.0
tunnel source 155.1.13.1 //source interface s0/1
tunnel destination 155.1.23.2 //destination int s0/3/1 di R2
!
interface FastEthernet0/0
ip address 155.1.146.1 255.255.255.0
!
interface Serial0/1
ip address 155.1.13.1 255.255.255.0
!
router eigrp 2
network 155.1.13.1 0.0.0.0
no auto-summary
!
router bgp 2
neighbor 155.1.12.2 remote-as 2
neighbor 155.1.12.2 next-hop-self
neighbor 155.1.146.4 remote-as 3
no auto-summary
!

R2
!
interface Tunnel1
ip address 155.1.12.2 255.255.255.0
tunnel source 155.1.23.2
tunnel destination 155.1.13.1
!
interface Serial0/3/0
ip address 155.1.0.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 155.1.0.5 205 broadcast
!
interface Serial0/3/1
ip address 155.1.23.2 255.255.255.0
!
router eigrp 2
network 155.1.23.2 0.0.0.0
no auto-summary
!
router bgp 2
neighbor 155.1.0.5 remote-as 1
neighbor 155.1.12.1 remote-as 2
neighbor 155.1.12.1 next-hop-self
no auto-summary
!

R3
!
interface Serial1/2
ip address 155.1.13.3 255.255.255.0
!
interface Serial1/3
ip address 155.1.23.3 255.255.255.0
!
router eigrp 2
network 155.1.13.3 0.0.0.0
network 155.1.23.3 0.0.0.0
no auto-summary
!

R4
!
interface FastEthernet0/0
ip address 204.12.1.4 255.255.255.0
!
interface FastEthernet0/1
ip address 155.1.146.4 255.255.255.0
!
router bgp 3
network 204.12.1.0
neighbor 155.1.146.1 remote-as 2
no auto-summary
!

R5
!
interface FastEthernet0/1
ip address 155.1.5.5 255.255.255.0
!
interface Serial1/0
ip address 155.1.0.5 255.255.255.0
encapsulation frame-relay IETF
frame-relay map ip 155.1.0.2 502 broadcast
!
router bgp 1
network 155.1.5.0 mask 255.255.255.0
neighbor 155.1.0.2 remote-as 2
no auto-summary
!

Verifikasi R4 sudah mendapat routing BGP dari R4 begitu juga sebalikny.
Selain itu R4 bisa ping ke R5.

R4#
R4#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C    204.12.1.0/24 is directly connected, FastEthernet0/0
155.1.0.0/24 is subnetted, 2 subnets
C       155.1.146.0 is directly connected, FastEthernet0/1
B       155.1.5.0 [20/0] via 155.1.146.1, 00:43:17

R4#
R4#sh ip bgp
BGP table version is 3, local router ID is 204.12.1.4
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 155.1.5.0/24     155.1.146.1                            0 2 1 i
*> 204.12.1.0       0.0.0.0                  0         32768 i

R4#
R4#
R4#p 155.1.5.5 so 204.12.1.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.5.5, timeout is 2 seconds:
Packet sent with a source address of 204.12.1.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/125/128 ms
R4#

Traceroute dari R4 juga menunjukkan bahwa BGP melalui interface Tunnel.

R4#traceroute 155.1.5.5 sou 204.12.1.4

Type escape sequence to abort.
Tracing the route to 155.1.5.5

1 155.1.146.1 4 msec 0 msec 0 msec
2 155.1.12.2 40 msec 40 msec 40 msec
3 155.1.0.5 68 msec *  64 msec
R4#

Juga berlaku sebaliknya. R5 bisa ping ke R4.

R5#sh ip route

Gateway of last resort is not set

B    204.12.1.0/24 [20/0] via 155.1.0.2, 00:48:00
155.1.0.0/24 is subnetted, 2 subnets
C       155.1.0.0 is directly connected, Serial1/0
C       155.1.5.0 is directly connected, FastEthernet0/1
R5#

R5#sh ip bgp
BGP table version is 3, local router ID is 155.1.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 155.1.5.0/24     0.0.0.0                  0         32768 i
*> 204.12.1.0       155.1.0.2                              0 2 3 i

R5#

R5#ping 204.12.1.4 so 155.1.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 204.12.1.4, timeout is 2 seconds:
Packet sent with a source address of 155.1.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/124/128 ms
R5#

Dengan ini kita punya alternatif lain untuk menghubungkan dua AS yang transit melalui non-BGP router. Bisa dengan redistribute dan satu lagi yang kita baru praktekkan yaitu dengan menggunakan Tunnelling.

.end.

Comments»

No comments yet — be the first.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: