jump to navigation

OSPF : Ingress filtering dengan distribute list dan route-map July 13, 2009

Posted by ZoeL in Cisco, Router Simulator.
Tags: , , ,
trackback

Di post blog sebelumnya, proses filtering dilakukan dengan melakukan filter spesifik ke subnet. Kali ini kita coba lakukan filtering berdasarkan sumber router pengirim.

scenario prefix-list filtering LSA type 3 network for OSPF

Masih mengambil contoh diagram yang sama dengan OSPF : Filter LSA Inter-Area dengan prefix-list, buat routing ke arah nullo (null 0 adalah interface virtual yang dijadikan tempat pembuangan data, kali ini digunakan untuk menjadi seakan2 atau pura2nya sebuah network existing yang akan di redistribute ke routing existing OSPF). Routing null0 tersebut kemudian di redistribute ke masing2 routing OSPF. R5 dan R6 lalu akan memiliki sebuah network external type 2 (LSA E2) yang menjadi objek percobaan untuk kita filter.

Berbeda dengan metode ingress filter sebelumnya, kali ini kita akan mencoba filter deny langsung spesifik ke tipe OSPF External type 2.  Selain itu, filter dilakukan bukan dengan menyatakan subnet yang ingin di blok, tetapi berdasarkan sumber router pengirim. Sumber router pengirim diidentifikasi dari ospf router-id.  Untuk R5 router-id adalah 150.1.5.5 dan R6 adalah 150.1.6.6.

Ingress filtering yang kita coba ini, merupakan filter lokal yang efektif di router R1 dan R4 (lokasi di mana filter dijalankan). Tetapi R5 masih tetap menerima  LSA dari R6 dan begitu juga sebaliknya.

Install routing static di R5 dan R6 ke arah null dan redistribute ke OSPF routing.

R5
ip route 160.1.50.0 255.255.255.0 Null0
!
router ospf 1
redistribute static subnets
!

R6
ip route 160.1.60.0 255.255.255.0 Null0
!
router ospf 1
redistribute static subnets

verifikasi dari R1 dan R4 bahwa routing null0 dari R5 dan R6 muncul sebagai router ospf type E2 (external).

R1#sh ip route ospf
160.1.0.0/24 is subnetted, 2 subnets
O E2    160.1.50.0 [110/20] via 155.1.0.5, 00:00:08, Serial0/0
O E2    160.1.60.0 [110/20] via 155.1.146.6, 00:00:08, FastEthernet0/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O       150.1.6.6/32 [110/2] via 155.1.146.6, 00:00:08, FastEthernet0/0
O       150.1.5.5/32 [110/65] via 155.1.0.5, 00:00:08, Serial0/0
O       150.1.4.4/32 [110/2] via 155.1.146.4, 00:00:08, FastEthernet0/0
R1#

R4#sh ip route ospf
160.1.0.0/24 is subnetted, 2 subnets
O E2    160.1.50.0 [110/20] via 155.1.0.5, 00:00:04, Serial0/0
O E2    160.1.60.0 [110/20] via 155.1.146.6, 00:00:04, FastEthernet0/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O       150.1.6.6/32 [110/2] via 155.1.146.6, 00:00:04, FastEthernet0/0
O       150.1.5.5/32 [110/65] via 155.1.0.5, 00:00:04, Serial0/0
O       150.1.1.1/32 [110/2] via 155.1.146.1, 00:00:04, FastEthernet0/0
R4#

Filter routing OSPF type E2 yang dari R6 dengan menggunakan 150.1.6.6 sebagai router-id dan diharapkan network 160.1.60.0 akan denied.

R1 & R4

!
router ospf 1
distribute-list route-map filter in //buat sebuah filter dengan distribute list menggunakan route-map//
!
route-map filter deny 10
match ip route source 1  //match dengan access-list 1, ip yang menjadi router-id//
match route-type external type-2 //match dengan routing ospf external type-2//
!
access-list 1 permit 150.1.6.6
!

verifikasi :

Subnet 160.1.60.0 (E2) hilang dari routing tabel R1 dan R4

R1#sh ip route ospf
160.1.0.0/24 is subnetted, 1 subnets
O E2    160.1.50.0 [110/20] via 155.1.0.5, 00:08:00, Serial0/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O       150.1.6.6/32 [110/2] via 155.1.146.6, 00:08:00, FastEthernet0/0
O       150.1.5.5/32 [110/65] via 155.1.0.5, 00:08:00, Serial0/0
O       150.1.4.4/32 [110/2] via 155.1.146.4, 00:08:00, FastEthernet0/0

R4#sh ip route ospf
160.1.0.0/24 is subnetted, 1 subnets
O E2    160.1.50.0 [110/20] via 155.1.0.5, 00:00:08, Serial0/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O       150.1.6.6/32 [110/2] via 155.1.146.6, 00:00:08, FastEthernet0/0
O       150.1.5.5/32 [110/65] via 155.1.0.5, 00:00:08, Serial0/0
O       150.1.1.1/32 [110/2] via 155.1.146.1, 00:00:08, FastEthernet0/0
R4#

subnet 160.1.60.0 (E2) masih tetap ada di R5 dan R6

R5#sh ip route ospf
155.1.0.0/24 is subnetted, 2 subnets
O IA    155.1.146.0 [110/65] via 155.1.0.4, 01:30:16, Serial1/0
[110/65] via 155.1.0.1, 01:30:16, Serial1/0
160.1.0.0/24 is subnetted, 2 subnets
O E2    160.1.60.0 [110/20] via 155.1.0.4, 01:29:36, Serial1/0
[110/20] via 155.1.0.1, 01:29:36, Serial1/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA    150.1.6.6/32 [110/66] via 155.1.0.4, 01:29:41, Serial1/0
[110/66] via 155.1.0.1, 01:29:41, Serial1/0
O IA    150.1.4.4/32 [110/65] via 155.1.0.4, 01:32:17, Serial1/0
O IA    150.1.1.1/32 [110/65] via 155.1.0.1, 01:32:17, Serial1/0
R5#

R6#sh ip route ospf
155.1.0.0/24 is subnetted, 2 subnets
O IA    155.1.0.0 [110/65] via 155.1.146.4, 01:30:00, FastEthernet0/0
[110/65] via 155.1.146.1, 01:30:00, FastEthernet0/0
160.1.0.0/24 is subnetted, 2 subnets
O E2    160.1.50.0 [110/20] via 155.1.146.4, 01:29:49, FastEthernet0/0
[110/20] via 155.1.146.1, 01:29:49, FastEthernet0/0
150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA    150.1.5.5/32 [110/66] via 155.1.146.4, 01:30:00, FastEthernet0/0
[110/66] via 155.1.146.1, 01:30:00, FastEthernet0/0
O       150.1.4.4/32 [110/2] via 155.1.146.4, 01:30:00, FastEthernet0/0
O       150.1.1.1/32 [110/2] via 155.1.146.1, 01:30:00, FastEthernet0/0
R6#

.end.

Comments»

1. ZoeL - December 4, 2010

distribute-list itu mekanisme filtering untuk route update di dalam routing protocol, sedangkan route-map bisa di sebut untuk me-customize routing paket yang lewat di interface router.

jadi…
kalau gak ingin sebuah subnet masuk ke dalam ospf process maka pasang distribute-list.

kalau pengen rubah jalur paket, atau pengen menghalangi subnet masuk atau memberikan label, gunakan route-map.

smoga cukup jelas.

2. Barly Wicaksono - November 29, 2010

Perbedaan mendasar antara distribute list dan route map apa ya?

trims.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: