jump to navigation

EIGRP Unequal-Cost Load-Balancing July 9, 2009

Posted by ZoeL in Cisco, Routing.
Tags: ,
trackback

Ketika Router (EIGRP) memiliki beberapa path (jalur) ke point yang sama tetapi memiliki besar bandwidth-nya berlainan (unequal), EIGRP memiliki kemampuan untuk melakukan Load-Balance dengan membagi rasio paket berdasarkan perintah parameter variance.

Contoh :

unequal-cost load-balance

R1
!
interface Loopback0
ip address 155.1.4.4 255.255.255.0
!
interface Serial0/0
bandwidth 256
ip address 155.1.0.4 255.255.255.0
encapsulation frame-relay
frame-relay map ip 155.1.0.5 405 broadcast
no frame-relay inverse-arp
!
interface Serial0/1
bandwidth 64
ip address 155.1.45.4 255.255.255.0
!
router eigrp 100
network 155.1.0.4 0.0.0.0
network 155.1.4.4 0.0.0.0
network 155.1.45.4 0.0.0.0
no auto-summary
!

R2
!
interface Loopback0
ip address 155.1.5.5 255.255.255.0
!
interface Serial1/0
bandwidth 256
ip address 155.1.0.5 255.255.255.0
encapsulation frame-relay
frame-relay map ip 155.1.0.4 504 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
bandwidth 64
ip address 155.1.45.5 255.255.255.0
!
router eigrp 100
variance 4

network 155.1.0.5 0.0.0.0
network 155.1.5.5 0.0.0.0
network 155.1.45.5 0.0.0.0
no auto-summary
!

Verifikasi :

R1
R1#sh ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

155.1.0.0/24 is subnetted, 4 subnets
C       155.1.0.0 is directly connected, Serial0/0
C       155.1.4.0 is directly connected, Loopback0
D       155.1.5.0 [90/10639872] via 155.1.0.5, 00:46:41, Serial0/0
C       155.1.45.0 is directly connected, Serial0/1

R1#sh ip eigr neighb
IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

(sec)         (ms)       Cnt Num
1   155.1.0.5               Se0/0            138 01:07:20   39   570  0  16
0   155.1.45.5              Se0/1             10 01:08:11  349  2280  0  15

R1#sh ip eigr topo
IP-EIGRP Topology Table for AS(100)/ID(155.1.4.4)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 155.1.0.0/24, 1 successors, FD is 10511872
via Connected, Serial0/0
P 155.1.4.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 155.1.5.0/24, 1 successors, FD is 2297856
via 155.1.0.5 (10639872/128256), Serial0/0
via 155.1.45.5 (40640000/128256), Serial0/1
P 155.1.45.0/24, 1 successors, FD is 40512000
via Connected, Serial0/1

R1#sh ip route 155.1.5.5
Routing entry for 155.1.5.0/24
Known via “eigrp 100”, distance 90, metric 10639872, type internalRedistributing via eigrp 100
Last update from 155.1.0.5 on Serial0/0, 00:57:39 ago
Routing Descriptor Blocks:
* 155.1.0.5, from 155.1.0.5, 00:57:39 ago, via Serial0/0
Route metric is 10639872, traffic share count is 1
Total delay is 25000 microseconds, minimum bandwidth is 256 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

R2

R2#sh ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set
155.1.0.0/24 is subnetted, 4 subnets

C       155.1.0.0 is directly connected, Serial1/0
D       155.1.4.0 [90/10639872] via 155.1.0.4, 00:52:43, Serial1/0
[90/40640000] via 155.1.45.4, 00:52:43, Serial1/1
C       155.1.5.0 is directly connected, Loopback0
C       155.1.45.0 is directly connected, Serial1/1

R2#sh ip eig nei
IP-EIGRP neighbors for process 100

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type (sec)         (ms)       Cnt Num

1   155.1.0.4               Se1/0        166 01:13:02   39   570  0  33
0   155.1.45.4              Se1/1         10 01:13:04   18  2280  0  32

R2#sh ip eig topo
IP-EIGRP Topology Table for AS(100)/ID(155.1.5.5)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 155.1.0.0/24, 1 successors, FD is 10511872
via Connected, Serial1/0
P 155.1.4.0/24, 1 successors, FD is 2297856
via 155.1.0.4 (10639872/128256), Serial1/0
via 155.1.45.4 (40640000/128256), Serial1/1
P 155.1.5.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 155.1.45.0/24, 1 successors, FD is 40512000
via Connected, Serial1/1

R2#sh ip route 155.1.4.4
Routing entry for 155.1.4.0/24
Known via “eigrp 100”, distance 90, metric 10639872, type internal
Redistributing via eigrp 100
Last update from 155.1.45.4 on Serial1/1, 00:56:19 ago

Routing Descriptor Blocks:
* 155.1.0.4
, from 155.1.0.4, 00:56:19 ago, via Serial1/0
Route metric is 10639872, traffic share count is 80
Total delay is 25000 microseconds, minimum bandwidth is 256 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
155.1.45.4, from 155.1.45.4, 00:56:19 ago, via Serial1/1
Route metric is 40640000, traffic share count is 21
Total delay is 25000 microseconds, minimum bandwidth is 64 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

Penjelasan :

Koneksi R1 dan R2 memiliki dua buah jalur dengan path1:serial to serial sebesar 64 kbps, dan path2:frame-relay 256 kbps. Secara otomatis, EIGRP memilih frame-relay yang memiliki bandwidth lebih besar.

Untuk mengaktifkan fungsi Unequal-Cost Load-Balancing, gunakan parameter variance yang diletakkan di bawah command router eigrp. Variance merupakan sebuah angka multiplier yang digunakan agar eigrp membagi secara proporsional paket-paket melalui beberapa path.

Berikut penjelasan mendapatkan nilai variance untuk Router R2.

Path 1 : Serial-To-Serial metric : 40640000 (dengan bandwidth 256kbps)
Path 2 : Frame-Relay metric : 10639872 (deangan bandwidth 64kbps)

Path2 memiliki nilai (value) yang lebih kecil dari path1. Untuk dapat melewati angka path1, path 2 dikalikan (multiply) dengan 4. ==> 10639872 x 4 = 42559488

Berarti, multiplier 4 memiliki nilai lebih dekat ke 40640000 (path1). Karena itu, angka 4 ini dijadikan nilai variance untuk routing EIGRP.

Setelah mendapatkan nilai variance, makan bisa di peroleh nilai proporsional paket yang dilewatkan untuk path1 dan path2 :

= path1/path2 = 40640000/10639872 = 3.81 = dibulatkan menjadi 4

Dan routing EIGRP menggunakan rasio 4:1 untuk jalur path1 dan path2. Maksudnya : 4 Paket ke path1 setelah itu 1 paket ke path2. Begitu seterusnya.

Dari  sh ip route 155.1.4.4 yang ada di R2, diperoleh angka 80:21:

R2#sh ip route 155.1.4.4
Routing entry for 155.1.4.0/24
Known via “eigrp 100”, distance 90, metric 10639872, type internal
Redistributing via eigrp 100
Last update from 155.1.45.4 on Serial1/1, 00:56:19 ago
Routing Descriptor Blocks:
* 155.1.0.4
, from 155.1.0.4, 00:56:19 ago, via Serial1/0
Route metric is 10639872, traffic share count is 80
Total delay is 25000 microseconds, minimum bandwidth is 256 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
155.1.45.4, from 155.1.45.4, 00:56:19 ago, via Serial1/1
Route metric is 40640000, traffic share count is 21
Total delay is 25000 microseconds, minimum bandwidth is 64 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

155.1.0.4 memiliki traffic share 80, dan 155.1.45.4 memiliki traffic share 21
80 : 21 = 4 :1

Note : Path yang bisa di gunakan untuk unequal-cost load-balance hanya path yang menjadi Feasible Successor.
Feasible Successor adalah path yang menjadi alternatif apabila best-path (feasible-distance) mengalami kegagalan (down).

.end.

Comments»

1. titis - June 3, 2010

siiiipppp


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: