jump to navigation

Konfigurasi untuk RSPAN (Remote SPAN (Switched Port Analyzer)) March 4, 2008

Posted by ZoeL in Cisco, Switching.
Tags: , ,
trackback

SPAN (Switched Port Analyzer), berfungsi untuk menganalisa aliran trafik dari port / vlan sebuah switch.

SPAN menduplikat (mirroring) trafik dari source ke destination. SPAN hanya berjalan lokal, dan tidak bisa digunakan pada topologi yang menggunakan switch lebih dari satu.

Untuk topologi network yang menggunakan banyak switch, bisa menggunakan RSPAN (Remote SPAN). RSPAN menggunakan remote vlan untuk monitoring.

Pada SPAN dan RSPAN, port / vlan yang dijadikan destination tidak bisa digunakan untuk komunikasi. Interface tersebut hanya bisa digunakan untuk monitoring (bisa lihat dengan command show interface.

Untuk menganalisa trafik yang lewat gunakan aplikasi Network Analyzer (misal Wireshark, Ethereal, Solarwind tools, etc).

Berikut langkah – langkah untuk mengaktifkan mode RSPAN

  1. Pada Distribution dan Access switch, buat remote vlan (bukan vlan yang sama dengan vlan yang digunakan oleh port – port switch) Vlan ini khusus digunakan untuk monitoring dan nantinya dijadikan RSPAN destination di switch access dan menjadi source di switch distribution. Remote vlan pada distribution harus sama dengan remote vlan pada switch acceess)
    Example:
    Switch(config)# vlan 901
    Switch(config-vlan)# remote span
    Switch(config-vlan)# end
  2. Set trunking mode semua port yang menuju access switch dan distribution switch.
  3. Tentukan port (atau vlan) yang akan digunakan untuk monitoring (sniffer) di distribution switch.
  4. Buat sesi monitoring pada switch access dengan source vlan number atau interface, dan destination-nya ke remote vlanExample:
    Switch(config)# no monitor session 1
    Switch(config)# monitor session 1 source interface gigabitethernet1/0/1 tx
    Switch(config)# monitor session 1 source interface gigabitethernet1/0/2 rx
    Switch(config)# monitor session 1 source interface port-channel 12
    Switch(config)# monitor session 1 destination remote vlan 901
    Switch(config)# end
  5. Buat sesi monitoring pada switch distribution dengan source remote vlan, dan destination-nya ke interface/vlan yang akan digunakan untuk monitoring.Example:
    Switch(config)# monitor session 1 source remote vlan 901
    Switch(config)# monitor session 1 destination interface gigabitethernet2/0/1
    Switch(config)# endSwitch(config)# end
  6. Contoh Konfigurasi Access Switch
    !
    # interface trunking ke Distribution Switch
    # untuk menjalankan RSPAN, koneksi acces dan distribution harus menggunakan trunking.
    interface GigabitEthernet0/1
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface Vlan1
    ip address 172.11.36.246 255.255.0.0
    !
    ip default-gateway 172.11.36.254
    !
    # monitor pada session ke 1, source RSPAN dari vlan 1, di mirror ke remote vlan number 2 (vlan 2)
    monitor session 1 source vlan 1
    monitor session 1 destination remote vlan 2
    end
  7. Contoh Konfigurasi Distribution Switch
    !
    # interface trunking ke Access Switch
    # untuk menjalankan RSPAN, koneksi acces dan distribution harus menggunakan trunking.
    interface GigabitEthernet0/13
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface GigabitEthernet0/14
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface GigabitEthernet0/15
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface GigabitEthernet0/16
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface GigabitEthernet0/17
    switchport trunk encapsulation isl
    switchport mode trunk
    !
    interface Vlan1
    ip address 172.21.36.240 255.255.0.0
    !
    # monitor pada session ke 1, source rspan dari remote vlan number 2, di mirror ke inteface gi0/11
    monitor session 1 destination interface Gi0/11
    monitor session 1 source remote vlan 2
    !

Comments»

1. home defense products - July 1, 2013

magnificent points altogether, you just won a emblem new reader.
What may you recommend in regards to your post that you made a few days ago?
Any certain?

2. ZoeL - July 14, 2010

sayang sekali guwe belum pernah.. pinjem dunk kalau punya😀

3. hanif - July 8, 2010

maaf disini tidak ada tempat mengisi komentar, jd disini saja ya, apakah pengalaman dalam memasang IPS kedalam ASA, tolong sharing ilmnya ya kalau pernah.tk’s

ZoeL - January 10, 2014

udah lama ngga ngupdate blog nya.. haha. ok ok ntar gw bikin halamannya ya.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: